INICIO FUNCIONES MACROS VBA MANUALES GUÍAS TEMÁTICAS

APLICACIONES

EJEMPLOS

    cibersoft_arg@yahoo.com.ar     cibersoft.arg@gmail.com    .

 

MAPA DEL SITIO

INICIO

MANUALES

Herramientas Excel

Programación VBA

Formularios Excel

(Para Excel xls y xlsm)

 

GUÍAS TEMÁTICAS

Listas desplegables

Comparando datos

Imágenes en Excel

Correo desde Excel

Mover-Copiar datos

 Bucles

 

APLICACIONES

Gestor de Ventas

Gestor de Documentos

Gestor Contable

Gestor Consorcios

 

HERRAMIENTAS y FUNCIONES

Novedades Excel 2013

Herramientas nuevas

Ejemplo de funciones

Lista completa de funciones

(2003 al 2013 - descarga)

 

MACROS VBA

Conceptos básicos

Referencias a objetos

Instrucciones básicas

Trabajando con Libros
Trabajando con hojas
Trabajando con celdas
Trabajando con bucles
Trabajando con objetos

 

EJEMPLOS (descarga gratuita)

 

 

 

 

 

MANUALES PARA LAS 2  VERSIONES EXCEL

(xlsm y xls)

 

     

Página:  Anterior  1  [2]  3  4  5    Siguiente

 

FUNCIONES EXCEL

 

Clic aquí para descargar el listado completo de funciones para versiones Excel 2003-2007-2010-2013

 

 

NUEVAS FUNCIONES EN EXCEL 2013

 

Son varias las funciones agregadas en esta versión 2013. Solo mostraré algunos casos que seguramente serán de uso frecuente.

A partir del ejemplo 5 son fórmulas aptas también para versiones anteriores de Excel.

 

 

EJEMPLO 1: evitar resultados con error  N/A

 

Uso de la función SI.ND

 

 

 

 

EJEMPLO 2: detectar si una celda contiene fórmula

 

Uso de la función ESFORMULA

 

Una de las funciones esperadas: poder evaluar si una celda contiene fórmula (devolverá Verdadero) o no, en ese caso devolverá Falso.

Mirando la imagen anterior, la siguiente fórmula devolverá Verdadero:

=ESFORMULA(F4)

 

En una fórmula SI:

=SI(ESFORMULA(F4);"SI";"NO")

 

 

EJEMPLO 3: obtener la fórmula como cadena de texto.

 

Uso de la función FORMULATEXTO

 

Hasta ahora, para conocer la fórmula que nos devuelve un valor en una celda teníamos que seleccionarla y observar en la 'barra de fórmulas' la sintaxis de la misma. O sinó con el atajo de teclado    o con la opción 'Mostrar fórmula' del menú Análisis.

 

Ahora, si deseamos revisar o hacer el seguimiento de alguna fórmula, bastará con escribir en alguna celda:

=FORMULATEXTO(F4)   

lo que nos devolverá según el ejemplo de la imagen anterior el 'texto': =SI.NOD("No existe";.....)

 

 

 

EJEMPLO 4: obtener la cantidad de días entre 2 fechas

 

Uso de la función DIAS

a - Fechas en celdas: 

 

      =DIAS(A2;B2)

 

 

b - Fechas como datos en la misma función.

 

 (van entre comillas)

 

 

Observar que es indistinto el uso de años de 2 o 4 dígitos, como así también meses de 1 o 2 dígitos.

 

      =DIAS("20/1/14";"25/2/2014")

 

 

 

EJEMPLO 5: obtener el n de hoja de una referencia y el total de hojas del libro.

 

Uso de la funciones HOJA  y  HOJAS

 

 

La función HOJA nos indica en qué n de hoja se encuentra alguna referencia,  como un nombre de rango.

 

La función HOJAS nos devuelve el total de hojas que contiene el libro incluyendo las hojas ocultas y hojas de gráficos y macros.

 

 

Página:  Anterior  1  [2]  3  4  5    Siguiente

::: Recomienda esta página :::

Servicio gratuito de Galeon.com